libde265: Multiple vulnerabilities — GLSA 201811-06

Multiple vulnerabilities have been found in libde265, the worst of which allows remote attackers to execute arbitrary code.

Affected Packages

media-libs/libde265 on all architectures
Affected versions < 1.0.3
Unaffected versions >= 1.0.3

Background

Open h.265 video codec implementation.

Description

Multiple vulnerabilities have been discovered in libde265. Please review libde265 changelog referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted media file using libde265 or linked applications, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All libde265 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/libde265-1.0.3"
 

References

Release Date
November 10, 2018

Latest Revision
November 10, 2018: 1

Severity
normal

Exploitable
remote

Bugzilla entries