PHP: Multiple vulnerabilities — GLSA 201812-01

Multiple vulnerabilities have been found in PHP, the worst of which could result in a Denial of Service condition.

Affected Packages

dev-lang/php on all architectures
Affected versions < 5.6.38
< 7.0.32
< 7.1.22
< 7.2.10
Unaffected versions >= 5.6.38
>= 7.0.32
>= 7.1.22
>= 7.2.10

Background

PHP is an open source general-purpose scripting language that is especially suited for web development.

Description

Multiple vulnerabilities have been discovered in PHP. Please review the referenced CVE identifiers for details.

Impact

An attacker could cause a Denial of Service condition or obtain sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All PHP 5.6.X users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-5.6.38"
 

All PHP 7.0.X users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-7.0.32"
 

All PHP 7.1.X users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-7.1.22"
 

All PHP 7.2.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-7.2.10"
 

References

Release Date
December 02, 2018

Latest Revision
December 03, 2018: 3

Severity
normal

Exploitable
local, remote

Bugzilla entries