Keepalived: Multiple vulnerabilities — GLSA 201903-01

Multiple vulnerabilities have been found in Keepalived, the worst of which could allow an attacker to cause Denial of Service condition.

Affected Packages

sys-cluster/keepalived on all architectures
Affected versions < 2.0.10
Unaffected versions >= 2.0.10

Background

Keepalived is a strong & robust keepalive facility to the Linux Virtual Server project.

Description

Multiple vulnerabilities have been discovered in keepalived. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could send a specially crafted request possibly resulting in a Denial of Service condition. A local attacker could perform symlink attacks to overwrite arbitrary files with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All Keepalived users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-cluster/keepalived-2.0.10"
 

References

Release Date
March 10, 2019

Latest Revision
March 10, 2019: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries