XRootD: Remote code execution — GLSA 201903-11

A vulnerability was discovered in XRootD which could lead to the remote execution of code.

Affected Packages

net-libs/xrootd on all architectures
Affected versions < 4.8.3
Unaffected versions >= 4.8.3

Background

A project that aims at giving high performance, scalable, and fault tolerant access to data repositories of many kinds.

Description

A shell command injection was discovered in XRootD.

Impact

A remote attacker could execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All XRootD users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/xrootd-4.8.3"
 

References

Release Date
March 14, 2019

Latest Revision
March 14, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries