Apache: Multiple vulnerabilities — GLSA 201903-21

Multiple vulnerabilities have been found in Apache Web Server, the worst of which could result in a Denial of Service condition.

Affected Packages

www-servers/apache on all architectures
Affected versions < 2.4.38-r1
Unaffected versions >= 2.4.38-r1

Background

The Apache HTTP server is one of the most popular web servers on the Internet.

Description

Multiple vulnerabilities have been discovered in Apache. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker can possibly cause a Denial of Service condition or could bypass mod_session_cookie expiration time.

Workaround

There is no known workaround at this time.

Resolution

All Apache users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/apache-2.4.38-r1"
 

References

Release Date
March 28, 2019

Latest Revision
March 28, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries