Cairo: Denial of Service — GLSA 201904-01

Multiple vulnerabilities were found in Cairo, the worst of which could cause a Denial of Service condition.

Affected packages

x11-libs/cairo on all architectures
Affected versions < 1.16.0-r3
Unaffected versions >= 1.16.0-r3

Background

Cairo is a 2D vector graphics library with cross-device output support.

Description

Multiple vulnerabilities have been discovered in Cairo. Please review the CVE identifiers referenced below for details.

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

All Cairo users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/cairo-1.16.0-r2"
 

References

Release date
April 02, 2019

Latest revision
April 02, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries