Libical: Multiple vulnerabilities — GLSA 201904-02

Multiple vulnerabilities have been found in Libical, the worst of which could result in a Denial of Service condition.

Affected Packages

dev-libs/libical on all architectures
Affected versions < 3.0.0
Unaffected versions >= 3.0.0

Background

An Open Source implementation of the iCalendar protocols and protocol data units.

Description

Multiple vulnerabilities have been discovered in Libical. Please review the referenced CVE identifiers for details.

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

All Libical users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libical-3.0.0"
 

References

Release Date
April 02, 2019

Latest Revision
April 02, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries