Mailman: Multiple vulnerabilities — GLSA 201904-10

Multiple vulnerabilities have been found in Mailman, the worst of which could result in the arbitrary execution of code.

Affected Packages

net-mail/mailman on all architectures
Affected versions < 2.1.29
Unaffected versions >= 2.1.29

Background

Mailman is a Python based mailing list server with an extensive web interface.

Description

Multiple vulnerabilities have been discovered in Mailman. Please review the referenced CVE identifier for details.

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

All Mailman users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-mail/mailman-2.1.29"
 

References

Release Date
April 08, 2019

Latest Revision
April 08, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries