Portage: Man-in-the-middle — GLSA 201904-11

A vulnerability in emerge-delta-webrsync and Portage could result in a man-in-the-middle attack.

Affected Packages

app-portage/emerge-delta-webrsync on all architectures
Affected versions < 3.7.4
Unaffected versions >= 3.7.4
sys-apps/portage on all architectures
Affected versions < 2.3.22
Unaffected versions >= 2.3.22

Background

Portage is the package management and distribution system for Gentoo.

Description

A vulnerability was discovered in emerge-delta-webrsync and Portage that did not properly validate the revocation status of GPG keys.

Impact

A remote attacker could conduct a man-in-the-middle attack. Please review the referenced bug for specific details.

Workaround

There is no known workaround at this time.

Resolution

All emerge-delta-webrsync users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=app-portage/emerge-delta-webrsync-3.7.4"
 

All Portage users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-apps/portage-2.3.22"
 

References

Release Date
April 08, 2019

Latest Revision
April 08, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries