Git: Multiple vulnerabilities — GLSA 201904-13

Multiple vulnerabilities have been found in Git, the worst of which could result in the arbitrary execution of code.

Affected Packages

dev-vcs/git on all architectures
Affected versions < 2.20.1
Unaffected versions >= 2.20.1

Background

Git is a free and open source distributed version control system designed to handle everything from small to very large projects with speed and efficiency.

Description

Multiple vulnerabilities have been discovered in Git. Please review the referenced CVE identifiers for details

Impact

Please review the referenced CVE identifier and bugs for details.

Workaround

There is no known workaround at this time.

Resolution

All Git users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.19.2"
 

References

Release Date
April 11, 2019

Latest Revision
April 11, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries