GnuTLS: Multiple vulnerabilities — GLSA 201904-14

Multiple vulnerabilities have been found in GnuTLS, the worst of which could result in a Denial of Service condition.

Affected Packages

net-libs/gnutls on all architectures
Affected versions < 3.6.7
Unaffected versions >= 3.6.7

Background

GnuTLS is a secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them.

Description

Multiple vulnerabilities have been discovered in GnuTLS. Please review the CVE identifiers referenced below for details.

Impact

Please review the CVE identifiers referenced below for details.

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/gnutls-3.6.7"
 

References

Release Date
April 15, 2019

Latest Revision
April 15, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries