libTIFF: Denial of Service — GLSA 201904-15

A vulnerability in libTIFF could lead to a Denial of Service condition.

Affected packages

media-libs/tiff on all architectures
Affected versions < 4.0.10
Unaffected versions >= 4.0.10

Background

The TIFF library contains encoding and decoding routines for the Tag Image File Format. It is called by numerous programs, including GNOME and KDE applications, to interpret TIFF images.

Description

Please review the CVE identifier referenced below for details.

Impact

Please review the CVE identifier referenced below for details.

Workaround

There is no known workaround at this time.

Resolution

All tiff users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/tiff-4.0.10"
 

References

Release date
April 15, 2019

Latest revision
April 15, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries