Multiple vulnerabilities have been found in Ruby, the worst of which could lead to the remote execution of arbitrary code.
|Package||dev-lang/ruby on all architectures|
|Affected versions||< 2.4.9
|Unaffected versions||>= 2.4.9
Ruby is an interpreted object-oriented programming language. The elaborate standard library includes an HTTP server (“WEBRick”) and a class for XML parsing (“REXML”).
Multiple vulnerabilities have been discovered in Ruby. Please review the CVE identifiers referenced below for details.
A remote attacker could execute arbitrary code, have unauthorized access by bypassing intended path matching or cause a Denial of Service condition.
There is no known workaround at this time.
All Ruby 2.4.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/ruby-2.4.9:2.4"
All Ruby 2.5.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/ruby-2.5.7:2.5"
March 13, 2020
March 13, 2020: 1