Multiple vulnerabilities have been found in Apache Tomcat, the worst of which could lead to arbitrary code execution.
|Package||www-servers/tomcat on all architectures|
|Affected versions||< 8.5.51
|Unaffected versions||>= 8.5.51
Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.
Multiple vulnerabilities have been discovered in Apache Tomcat. Please review the CVE identifiers referenced below for details.
An attacker could possibly smuggle HTTP requests or execute arbitrary code.
There is no known workaround at this time.
All Apache Tomcat 7.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.100:7"
All Apache Tomcat 8.5.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-servers/tomcat-8.5.51:8.5"