Apache Tomcat: Multiple vulnerabilities — GLSA 202003-43

Multiple vulnerabilities have been found in Apache Tomcat, the worst of which could lead to arbitrary code execution.

Affected packages

www-servers/tomcat on all architectures
Affected versions < 8.5.51
Unaffected versions revision >= 8.5.51
revision >= 7.0.100

Background

Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.

Description

Multiple vulnerabilities have been discovered in Apache Tomcat. Please review the CVE identifiers referenced below for details.

Impact

An attacker could possibly smuggle HTTP requests or execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All Apache Tomcat 7.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.100:7"
 

All Apache Tomcat 8.5.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/tomcat-8.5.51:8.5"
 

References

Release date
March 19, 2020

Latest revision
March 20, 2020: 2

Severity
normal

Exploitable
remote

Bugzilla entries