libssh: Denial of Service — GLSA 202011-05

A vulnerability in libssh could lead to a Denial of Service condition.

Affected packages

net-libs/libssh on all architectures
Affected versions < 0.9.5
Unaffected versions >= 0.9.5

Background

libssh is a multiplatform C library implementing the SSHv2 protocol on client and server side.

Description

libssh was found to have a NULL pointer dereference in tftpserver.c if the function ssh_buffer_new returns NULL.

Impact

An attacker could cause a possible Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All libssh users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/libssh-0.9.5"
 

References

Release date
November 03, 2020

Latest revision
November 03, 2020: 1

Severity
normal

Exploitable
remote

Bugzilla entries