A vulnerability in OpenSSL might allow remote attackers to cause a Denial of Service condition.
|Package||dev-libs/openssl on all architectures|
|Affected versions||< 1.1.1i|
|Unaffected versions||>= 1.1.1i|
OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1/v1.1/v1.2/v1.3) as well as a general purpose cryptography library.
A null pointer dereference flaw was found in OpenSSL.
A remote attacker, able to control the arguments of the GENERAL_NAME_cmp function in an application linked against OpenSSL, could possibly cause a Denial of Service condition.
There is no known workaround at this time.
All OpenSSL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.1.1i"
December 23, 2020
December 23, 2020: 1